Thursday 3rd November 2016

Broadband Services Network Degradation - DDoS

Issue #486003

We are currently experiencing network degradation specifically international connectivity that is currently causing network constraints and connectivity issues to our servers. Our network engineers are working to resolve this asap. We apologise for any inconvenience or impact this is having.

Update: 4:57pm Network engineers have managed to mitigate the network issues now and continue to monitor the situation.